Oggi vedremo come correggere un problema che ho notato essere molto (troppo) presente sulle installazioni di Wordpress hostate su Aruba: la visualizzazione di pagine di errore 500 internal server error che capitano più spesso dopo l'upgrade di plugin/temi o del core di wordpress.

Personalmente ho lavorato su un paio di siti Wordpress installati su Aruba, e in entrambi mi è capitato almeno una volta questo stranissimo problema, subito dopo l'upgrade del core. L'ultima volta mi è capitato proprio l'altro ieri, con l'aggiornamento alla versione 3.4.

Bando alle ciance, vediamo come risolvere la questione. Andiamo per step.

1. Accedi al tuo pannello di controllo personale di Aruba loggatevi su admin.aruba.it con le vostre credenziali. Spostatevi su "Pannello gestione Hosting Linux"

2. Clicca sulla scheda "Strumenti ed Impostazioni", quindi clicca su "Riparazione Permissions"

3. Conferma l'operazione ed attendi qualche minuto.

L'attesa è necessaria in quanto Aruba modificherà ricorsivamente tutti i permessi di tutti i file e le cartelle presenti sul tuo archivio: ovviamente, va da sè che a maggior quantitativo di file, maggiore è il tempo da attendere per far sì che la modifica si propaghi a tutto il tuo webserver.

NOTA IMPORTANTE: questo è uno dei tanti problemi che possono scatenare un errore 500 Internal Server Error su Wordpress, e più in particolare su Wordpress+Aruba: questa guida potrebbe anche non funzionare nel tuo caso. Infatti, altre volte possono essere problemi nel file .htaccess o nella incompatibilità tra due plugin o tra plugin e temi a scatenare un errore simile, ma essendo questa procedura molto veloce val la pena di tentare :) se vi va bene, vi siete evitati un mal ti testa assicurato!